Well, the board is either fixed, or it's going to run terribly. Cross your fingers and hope for the best. I'm at my technical limit right now.

VZ58 feeding problems from "pistol mag" well adapter

VZOR 52, 52/57 & 58
Post Reply
Message
Author
Irons78
Registered User
Registered User
Posts: 18
Joined: Sat Jun 17, 2017 9:57 am
Age: 39
Location: Muskoka, Ontario
Canada

VZ58 feeding problems from "pistol mag" well adapter

#1 Post by Irons78 » Thu Aug 31, 2017 7:43 pm

Hi all - problem recently started occurring in my VZ58 sporter. It's in 5.56x45 and has the magwell adapter for the 10 round pistol mags (yes it's a Canadian thing!). Anyways recently I noted that the action is picking up the cartridge normally but the bullet is not clearing that small lip just below the entrance to the chamber. This results in the bullet being pushed back into the case. I've tried several mags and same thing, so it narrows down to the magwell adapter (I think). Anyone else have this problem (and even better, a fix!)?

One thing I tried, if it helps with diagnosis: I found that when shooting from a bipod, if my left hand pushes the mag forward and up, the gun cycles perfectly on semi-auto rapid fire. I've noticed some "slop" in the magwell adapter as well, it wiggles around. The mags also don't seem to sit tight in the well either, some movement.

Advice appreciated!

User avatar
Rapidrob
Global Moderator
Global Moderator
Posts: 274
Joined: Sat Jun 03, 2017 9:10 am
Age: 66
Location: New Mexico
United States of America

Re: VZ58 feeding problems from "pistol mag" well adapter

#2 Post by Rapidrob » Fri Sep 01, 2017 9:08 am

1. Open up the feed lips on the magazine to allow the round to sit just a little bit higher.
2. Round out the ledge in the receiver/barrel junction.
3. Try a rounded "Varmint" type bullet
Any of those should work.
Tin Can Sailor
'Nam Vet
NRA Endowment Member
President New Mexico Military Surplus Rifle Pistol Shooters

Irons78
Registered User
Registered User
Posts: 18
Joined: Sat Jun 17, 2017 9:57 am
Age: 39
Location: Muskoka, Ontario
Canada

Re: VZ58 feeding problems from "pistol mag" well adapter

#3 Post by Irons78 » Sat Sep 02, 2017 10:11 pm

Thanks Rob! I looked close today and noticed that the right side plastic tab on the adapter is gone, probably snapped off when I was shooting last. So the adapter is pooched. I'm going to remove the adapter and get a few of the original 556 mags and call'r a day. :D

Post Reply

Return to “Czech Rifles”

Who is online

Users browsing this forum: No registered users and 1 guest